Bulletin Boards
Home Page
 FAQFAQ   SearchSearch   MembersMembers
 User Control PanelUser Control Panel   LoginLogin 

All times are UTC - 5 hours




Post new topic Reply to topic  [ 4 posts ] 
Author Message
PostPosted: Thu May 06, 2004 11:48 am 
I'm on Ortho Evera better known as "the patch" I've been on birthcontrol for about 2 years now. I started a new cycle tuesday April 27th but they have you put a new patch on that saturday so I'm not sure if that counts as my first day or does the first day of bleeding count. Anyways I've been real sick feeling since sunday. I've had to use the bathroom alot , dizzy, feel like vomitting at any moment but don't, hot flashes and I've noticed a white kinda smelly (sorry TMI) discharge. I guess my real question is should I stop going to the tanners and getting my nails done I don't think the nail part would hurt even though they have some very harsh chemical's you can inhale. I did one of those online ovulation calculators (btw 24 day cycle) and it said I was furtel from sunday may 2-sunday may 9 . We had sex on sunday may 2. Ugh this is so confusing. I just don't want to do anything wrong if I am but I'm on birthcontrol and it's worked so far why wouldn't it now? let me know what you guys think thanks!


Top
  
 
 Post subject: reply to collegegirl
PostPosted: Thu May 06, 2004 11:54 am 
Offline

Joined: Thu Apr 29, 2004 4:21 pm
Posts: 11
I was also on the patch for 2 years. I loved it! I just went off of it in Jan in hopes to get prego. I know there was some fuss on the news a while ago for those buying the patch over the Internet and it was fake. However, if you have gotten them through the pharmacy and you have been consistent in taking them there should be no problem..although there is that 1%. You should not be fertile or get prego on the patch if you are taking it as shown.

It sounds like your comment on the "smell" may lead to an infection of some sort vs. prego. Have you called your Dr?


Top
 Profile  
 
 Post subject:
PostPosted: Thu May 06, 2004 12:03 pm 
No I haven't called the dr yet because I don't have insurance but I will when I start my new job monday. I use the patch right and I seem to like it but I'm just worried I've never felt like this before and it's really early to even start thinking about tests or whatnot I wish there was an instant way to find out hehe not all this waiting anyways so do you think I should stop going to the tanners or what?


Top
  
 
 Post subject: reply
PostPosted: Thu May 06, 2004 12:30 pm 
Offline

Joined: Thu Apr 29, 2004 4:21 pm
Posts: 11
Well...overall they say tanning is not good for you but I am no doctor. You would be so early though I am not even sure it would matter. Again, since you are on the patch and right on schedule I doubt you are prego...However, if you do have that smell and feel that way it may be a sign of an infection. You may want to search on the web under signs of UTI?

Good luck to you...sorry no help. Anyway...typically if you are prep it will not show symptoms like you are saying until after implantation. It typically takes place as I have discovered 9-10 days after you ovulated. I am not sure though if you ovulate when you are on the patch. I think that is the whole thing on the pill...it makes your body think you are pregnant and you do not ovulate?? Nor real sure on that either..


Top
 Profile  
 
Display posts from previous:  Sort by  
Post new topic Reply to topic  [ 4 posts ] 

All times are UTC - 5 hours


Who is online

Users browsing this forum: No registered users and 0 guests


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Search for:
Jump to:  
cron
Powered by phpBB® Forum Software © phpBB Group

phpBB SEO